Virtuous cycle

Bartlomiej Owczarek weblog

You are currently browsing the Virtuous cycle weblog archives for tag 'wordpress'.

Return to 'Virtuous cycle' home page

I improved this blog a bit

Hey, I didn’t even advertise it, but I made some long overdue changes to the blog. First of all, I changed, at last, categories that I use for posts, so now they make more sense:

It required a manual re-class of some 300 posts. Ugh.

But there is more – in addition to categories, I now also use tags:

This allows to navigate to post related to Poland, for example, or social lending. I’m usually quite skeptical about usability of tags, but in context of my blog I like them a lot.

Unfortunately, the upgrade to wordpress 2.5.1, that I had done before all these improvements, broke the gallery section. And apparently also google ads. For photos, I’m seriously considering outsourcing all this stuff to Flickr, so I don’t have to bother with endless tweaking of spgm script. Or continue waiting for someone to make gallery that integrates with wordpress and just works. As for ads, I have no idea why they are broken.

More importantly, in short term I expect to finish an intensive Kiev project, close social lending research that I did, and have more time for blogging. And a better position to blog in general. I might even post more often than once in a month. Stay tuned.

Upgrading to WordPress 2.0, third try, I call it a success

Another precious three hours and I managed to get WP2.0 working without errors, visible errors, at least. I repaired SPGM rewriting rules using trial and error approach, but it is now such a mess that I don’t even want to look at it.

As for added value, I started to use Akismet anti-spam plugin. I’m curious to see how it performs.

Upgrading to WordPress 2.0, second try, almost there

I found an article that helped me to bypass the original problem, here:

http://wordpress.org/support/topic/62057

The workaround seems quite rough and I’m not sure if there aren’t any side effects, but it does its job.

Everything seemed to be fine, except for the SPGM gallery, whose rewriting rules, as usual, got broken… I must roll back again and postpone this fun till weekend (2.5 hours wasted so far).

Upgrading to WordPress 2.0, first try, failed

I decided to upgrade to WordPress 2.0 this evening. First I started on my test site, ie. on the account I still have on the university server.

I copied the files, made database backup, uploaded new wordpress in, copied old files into its directory, renamed old wordpress installation to make the way for new one, renamed the new one to take over. Ran the upgrade script. Script said it worked. And the site itself… bingo, everything fine!

Looks cute, this new version, and this shiny post editor. Right away I start with my “production” facility.

I copied the files, made database backup, uploaded new wordpress in, copied old files into its directory, renamed old wordpress installation to make the way for new one, renamed the new one to take over. Ran the upgrade script. Script said it worked. And the site itself…

500 Internal Server Error

S H I T

1 hour of unsuccessful tries to repair the thing.

I rolled back. Thanks God the database backup was flawless…